Minor Software Update for Budgeting and Benchmarking UAT

Scheduled for Feb 4, 11:00 - 12:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 02, 2026 - 11:27 EST

Scheduled

In this scheduled event Suvoda will apply required software updates to the Budgeting and Benchmarking application in our UAT environment. During this time Suvoda systems do not expect downtime.

This update includes the following changes:
> Backward compatible quality fixes
Posted Feb 02, 2026 - 11:26 EST
This scheduled maintenance affects: Budgeting & Benchmarking UAT Environment (EnvisiX UAT).