Patient Payments (ClinCard) Service Degradation

Incident Report for Greenphire

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 09:15 EST

Investigating

Patient Payments (ClinCard) is currently experiencing a degradation in some payment and card assignment activities. Our teams are working to isolate and correct the issue as soon as possible. We thank you for your patience and apologize for any inconvenience this has caused. Please monitor our Status Page for updates.
Posted Dec 07, 2025 - 08:13 EST
This incident affected: Greenphire Patient Payments Production (ClinCard Production).