Site Payments Production Outage

Incident Report for Greenphire

Resolved

This incident has been resolved.
Posted May 13, 2026 - 13:43 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 13, 2026 - 12:39 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 13, 2026 - 12:39 EDT

Investigating

We are experiencing a service outage of the Site Payments application in our Production environment. Production APIs may also be inaccessible during this time. Our teams are working to isolate and correct the issue as soon as possible. We thank you for your patience and apologize for any inconvenience this has caused. Please monitor our Status Page for updates.
Posted May 13, 2026 - 11:50 EDT
This incident affected: Site Payments Production Environment (Study Setup and Invoice APIs Production, Site Payments Production).