Patient Payments (ClinCard) Service Degradation

Incident Report for Greenphire

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 13:35 EST

Investigating

Patient Payments (ClinCard) is currently experiencing a performance degradation in connectivity; some functions may be inaccessible. Our teams are working to isolate and correct the issue as soon as possible. We thank you for your patience and apologize for any inconvenience this has caused. Please monitor our Status Page for updates.
Posted Nov 03, 2025 - 17:24 EST
This incident affected: ClinCard Production Environment (ClinCard Production).