ClinCard Service Degradation

Incident Report for Greenphire

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 10:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2025 - 14:11 EDT

Investigating

ClinCard is currently investigating an issue affecting disbursement calculations within the Program Balance Detail Report.
We apologize for any inconvenience this may cause and appreciate your patience. Updates will be posted here as they become available.
Posted Sep 05, 2025 - 09:40 EDT
This incident affected: ClinCard Production Environment (ClinCard Production).